Skip to content
statance
MenuClose
high · CVSS 7.5

CVE-2026-68968

Apache Airflow: Authorization bypass in the Backfill API through conflicting interpretations of the backfill id

Published 12 Aug 2026 · Source updated 3 Nov 2026 · Retrieved 2026-11-04 15:09 UTC · This record may be stale; verify the source

Statance checks for CVE-2026-68968. Connected servers are checked automatically against the fixed versions their distribution or package ecosystem has published for it, including app dependency lockfiles. Check my servers ↗
Monitor this CVE ↗Full CVE monitoring on Pro and Business

What happened?

Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the `backfill_id` path segment failed to parse. The authorization dependency parsed it with `int()` while the route handler parsed it as pydantic's `NonNegativeInt`, which accepts values `int()` rejects (`1.0` coerces to `1`); FastAPI resolves dependencies before endpoint validation, so the two acted on different Dags. An authenticated user holding edit permission on any single Dag could therefore read, pause and cancel backfills belonging to any other Dag, including moving another Dag's queued runs to `failed`. No non-default configuration is required and backfill ids are sequential, so finding a target is trivial. Users are advised to upgrade to apache-airflow 3.3.1 or later, which parses the backfill id with the same type the routes declare.

Description supplied by CVE Program. Formatting is simplified; follow the original advisory for full details.

Affected software and versions

Source-provided software and version information
SoftwareVersion informationFixed version
apache-airflowApache Software Foundationaffected: 0 to < 3.0.0See vendor advisory
apache-airflow-coreApache Software Foundationaffected: 3.0.0 to < 3.3.1See vendor advisory

Version information comes from the source record and can include unaffected products and exceptions. Distribution packages may contain backported fixes: an older upstream version alone does not prove a server is affected.

Is it being exploited?

This CVE was not listed in the CISA catalogue at our last retrieval. This does not establish that exploitation is absent.

CISA data retrieved 2026-11-06 16:38 UTC. Check CISA ↗

How to respond

  1. Confirm the product, installed package version, and any configuration requirements in the vendor advisory.
  2. Follow the vendor’s remediation or workaround guidance in the references below. Structured fixed-version data is unavailable here; the publisher’s description may include a fix or workaround.
  3. Restart affected services if required, then verify the running version. Known exploitation may warrant investigation as well as patching.

Sources and remediation references

This public advisory does not determine whether a particular server is affected. Records are refreshed as sources change; verify urgent decisions against the original advisory.

← Browse the public CVE feed